Monitoring - A fix has been implemented and we are monitoring the results.
May 02, 2024 - 10:36 CDT
Identified - We've identified the issue and are beginning to see recovery
May 02, 2024 - 09:13 CDT
Investigating - We're seeing elevated network error rates impacting a subset of customers
May 02, 2024 - 06:32 CDT
Engagement: Airship Operational
90 days ago
99.99 % uptime
Today
Engagement: Web Viewer & Devices Operational
90 days ago
99.97 % uptime
Today
Engagement: Asset Processing Operational
90 days ago
99.89 % uptime
Today
Engagement: Value Platform ? Operational
90 days ago
100.0 % uptime
Today
Intelligence (formerly InsightSquared) ? Partial Outage
90 days ago
99.93 % uptime
Today
Coach (formerly ExecVision) ? Operational
90 days ago
99.51 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
May 2, 2024

Unresolved incident: Network degradation.

May 1, 2024

No incidents reported.

Apr 30, 2024
Resolved - The issue has been resolved
Apr 30, 17:30 CDT
Monitoring - A fix has been implemented and we are monitoring the results.
Apr 30, 16:44 CDT
Identified - The issue has been identified and a fix is being implemented.
Apr 30, 16:00 CDT
Investigating - Coach is experiencing a degraded speed of file processing, delaying calls from showing to users. We are investigating this issue.
Apr 30, 15:09 CDT
Apr 29, 2024

No incidents reported.

Apr 28, 2024

No incidents reported.

Apr 27, 2024

No incidents reported.

Apr 26, 2024

No incidents reported.

Apr 25, 2024

No incidents reported.

Apr 24, 2024

No incidents reported.

Apr 23, 2024

No incidents reported.

Apr 22, 2024

No incidents reported.

Apr 21, 2024

No incidents reported.

Apr 20, 2024

No incidents reported.

Apr 19, 2024

No incidents reported.

Apr 18, 2024
Resolved - This incident has been resolved.
Apr 18, 17:08 CDT
Update - We are continuing to see a recovery of the backlog, and we're actively monitoring progress.
Apr 18, 16:06 CDT
Monitoring - We've identified the issue and are monitoring the recovery
Apr 18, 15:14 CDT
Investigating - We are currently investigating this issue.
Apr 18, 15:09 CDT